Solusi Error phpmyadmin di Linux Mint 19

Solusi Error phpmyadmin di Linux Mint 19

24 Juli 2018
/ / /

Ketika menemukan error pada Linux Mint 19 dengan pesan error sebagai berikut phpmyadmin – count(): Parameter must be an array or an object that implements Countable dengan tampilan error seperti dibawah ini

Warning in ./libraries/sql.lib.php#601
count(): Parameter must be an array or an object that implements Countable

Backtrace

./libraries/sql.lib.php#2038: PMA_isRememberSortingOrder(array)
./libraries/sql.lib.php#1984: PMA_executeQueryAndGetQueryResponse(
array,
boolean true,
string 'alternativegirls',
string 'tgp_photo',
NULL,
NULL,
NULL,
NULL,
NULL,
NULL,
string '',
string './themes/pmahomme/img/',
NULL,
NULL,
NULL,
string 'SELECT * FROM `tgp_photo`',
NULL,
NULL,
)
./sql.php#216: PMA_executeQueryAndSendQueryResponse(
array,
boolean true,
string 'alternativegirls',
string 'tgp_photo',
NULL,
NULL,
NULL,
NULL,
NULL,
NULL,
string '',
string './themes/pmahomme/img/',
NULL,
NULL,
NULL,
string 'SELECT * FROM `tgp_photo`',
NULL,
NULL,
)
./index.php#53: include(./sql.php)

ternnyata solusi cukup mudah hanya menambahkan kurunng tutup seperti ini ) pada file sql.lib.php

Edit file /usr/share/phpmyadmin/libraries/sql.lib.php dengan perintah

sudo nano /usr/share/phpmyadmin/libraries/sql.lib.php

ganti tulisan: (count($analyzed_sql_results['select_expr'] == 1)

menjadi: ((count($analyzed_sql_results['select_expr']) == 1)

Restart apache

sudo service apache2 restart

Selamat mencoba, terima kasih dan sukses selalu untuk kita semua. (ms)

About Author

About Muhidin Saimin

Teacher, Trainer & Programmer

Tinggalkan Balasan

This site uses Akismet to reduce spam. Learn how your comment data is processed.