Solusi Error phpMyAdmin pada file plugin_interface.lib.php PHP7.2 di Linux Mint 19

Jika muncul error seperti ini

Warning in ./libraries/plugin_interface.lib.php#532

count(): Parameter must be an array or an object that implements Countable

dengan penyebab pustaka pada file phpmyadmin terjadi error. pada kasus saya kesalah terjadi di baris 551 di file plugin_interface.lib.php, edit dengan perintah

$ vi /usr/share/phpmyadmin/libraries/plugin_interface.lib.php +551
Perhatikan pada bagian ada di baris ke 551
if ($options != null && count($options) > 0) {

Pada perintah php version 7.2 kita tak dapat menggunakan  count() atau sizeof() dengan type array. Tambahkan  (array) untuk solusinya, menjadi:

if ($options != null && count((array)$options) > 0) {

Selamat mencoba, semoga sukses untuk kita semua. (ms)

 

 

Tinggalkan Balasan

This site uses Akismet to reduce spam. Learn how your comment data is processed.